ltu.social

no feed found - is ltu.social running 1.1.1 or higher?